Cisco 877, BeThere and Bridge Mode …

Configuration for a Cisco 877 router to transparently bridge a BeThere Internet connection so that the public IP address is passed through to an internal device.  Great for use with an ASA firewall. Essential config is highlighted in bold.

Update: Following an upgrade to Advanced IP Services on the same IOS revision, the configuration below broke and would no longer forward packets.  Disabling CEF at a global level fixes the problem but I’ve to do more investigation as to why.

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
enable secret 5 xxxxxxxxxxxxxxxxxxxxxx
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone GMT 0
!
!
dot11 syslog
ip cef
!
!
no ip domain lookup
!
!
!
!
!
archive
log config
hidekeys
!
!
!
bridge crb
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
 dsl operating-mode adsl2+
!
!
interface ATM0.101 point-to-point
 atm route-bridged ip
 pvc 0/101
bridge-group 1
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
!
interface Vlan999
 no ip address
 bridge-group 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
no modem enable
line aux 0
line vty 0 4
transport input ssh
!
scheduler max-task-time 5000
end