Putting a Cisco 887VA into bridge mode on Plusnet VDSL

The following config puts a Cisco 887VA connected to Plusnet via VDSL into bridge mode so that PPPoE can be passed on to a device sat directly behind such as an ASA Firewall or something similar.  The config assumes that said device is connected to port Fa0.

The key configuration statements are highlighted in bold.  It’s worth noting on the dot1Q sub-interface, Plusnet appear to use VLAN 101.  Other ISP’s may use different tags.

VLAN 3 (port Fa3) in this example is used for management of the router.

Current configuration : 1643 bytes
!
! Last configuration change at 20:17:51 UTC Sat Jul 29 2017 by *******
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash c880data-universalk9-mz.153-2.T4.bin
boot-end-marker
!
!
enable secret 5 *****************
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
memory-size iomem 10
!
!
no ip routing
!
!
!
!
!
!
no ip domain lookup
no ip cef
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn ********
license accept end user agreement
license boot module c880-data level advsecurity
!
!
username ******** privilege 15 secret 5 **********************
!
!
!
!
!
controller VDSL 0
firmware filename flash:VA_A_39m_B_38h3_24h.bin
modem UKfeature
!
!
!
!
!
!
bridge irb
!
!
!
!
interface Ethernet0
no ip address
no ip route-cache
!
interface Ethernet0.101
encapsulation dot1Q 101
no ip route-cache
bridge-group 1
!
interface ATM0
no ip address
no ip route-cache
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
no ip address
load-interval 30
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
switchport access vlan 3
no ip address
!
interface Vlan1
no ip address
ip virtual-reassembly in
no ip route-cache
load-interval 30
bridge-group 1
!
interface Vlan3
ip address 192.168.3.239 255.255.255.0
no ip route-cache
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
bridge 1 protocol ieee
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
transport input all
!
!
end

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.